Partial outage
Incident Report for Aptoma AS
Resolved
This incident has been resolved.
Posted 7 days ago. Jun 09, 2019 - 23:38 CEST
Investigating
We are currently investigating this issue.
Posted 8 days ago. Jun 09, 2019 - 20:32 CEST
This incident affected: DrPublish (DrPublish Backoffice).