Problems uploading images
Incident Report for Aptoma AS
Postmortem

The cause of this incident was a planned and proactive maintenance. The maintenance caused a performance issue on database-level on Aptoma Smooth Storage services. We have since rolled back this maintenance change, and we have found other methods to accomplish this form of maintenance. This means we will not experience this kind of issue by the same causes in the future.

Posted May 31, 2023 - 11:53 CEST

Resolved
This incident has been resolved, including the 900 stuck images.

If you still have issues, please contact support.

We are sorry for the problems caused.
Posted May 29, 2023 - 17:47 CEST
Monitoring
Image systems are working again in general. However some 900 images uploaded during the incident may be stuck. Re-uploading them again does not solve the issue.

A workaround exists: You have to edit the image locally (resize, crop a bit, or any way modify the original image a bit) before re-uploading it. This will solve the issue for this particular image.
Posted May 29, 2023 - 17:34 CEST
Identified
We have identified the issue and are deploying an update.
Posted May 29, 2023 - 17:20 CEST
Investigating
We are investigating an image with uploading and/or transforming images.
Posted May 29, 2023 - 17:16 CEST
This incident affected: Smooth Storage API (images, graphics and files).